Plugins You can find out about all the publicly available Grails plugins.

Provides Mail support to a running Grails application

supported by SpringSource

  • Tags : mail, messaging, javamail, grails2
  • Latest : 1.0.4
  • Last Updated: 07 March 2014
  • Grails version : 1.3 > *
60 votes

44% of Grails users

This plug-in provides a MailService class as well as configuring the necessary beans within the Spring ApplicationContext.

It also adds a "sendMail" method to all controller classes. A typical example usage is:

sendMail { to "fred@g2one.com","ginger@g2one.com" from "john@g2one.com" cc "marge@g2one.com", "ed@g2one.com" bcc "joe@g2one.com" subject "Hello John" text "this is some text" } Read more

Dependency :
compile ":mail:1.0.4"

Documentation Source Issues

Provides integration with Paypal's Instant Payment Notfication (IPN) system

  • Tags : paypal
  • Latest : 0.6.8
  • Last Updated: 17 July 2012
  • Grails version : 1.1 > *
3 votes

This plug-in allows Grails applications to integrate with Paypal and its Instant Payment Notification (IPN) system.

A PayPalController is provided that has a "notifyPaypal" action which deals with responses from the PayPal IPN. In order for this to function you need to enable IPN in your PayPal Profile under Profile / Instant Payment Notification Preferences and provide PayPal with the URL you have mapped the "notify" action to.

In order for this plug-in to function you must configure the followin...

Read more

Dependency :
compile ":paypal:0.6.8"

Documentation

Render RSS/Atom feeds with a simple builder

10 votes

This plugin adds a feedType and feedVersion parameters to the render method of controllers, which if passeda valid feed type such as "rss" or "atom" and a version will expect a closure to be passed with render,which will render a feed using a custom builder. The FeedBuilder used for this accepts entry and content nodes, any propertiesof which can be set within the builder. These are beans from the ROME API so all properties thereshould work. Read more

Dependency :
compile ":feeds:1.6"

Documentation Source Issues

Previous1..93949596979899100101102..109Next